675.cc • Triumph 675 Forum

3rd gen Daytona, Missing shift from 3rd to 4th

Discussion in 'How To's' started by aglareinmyeyes, May 28, 2020.

  1. aglareinmyeyes

    aglareinmyeyes

    Thread Starter

    5
    0
    1
    Location: Los Angeles CA
    3rd gen D 675 r
    Bazzaz quick shift
    Attack Performance rearsets, GP shift
    Track only
    Everything on the current setup worked flawlessly for 2.5 years of track days.
    The symptoms appeared quite quickly from not being apparent at all.

    On hard acceleration (straights) when I try to shift from 3rd to 4th I get a bit of a clank/grind and it won't grab 4th. Kind of just falls into a neutral between gears. Sometimes it will grab on the second try but probably because I have already let off the throttle because of the missed shift.

    As a test I disconnected the quick shifter and can duplicate the issue under hard acceleration if I don't fully pull in the clutch.

    I have the bike up on the lift ready to start ripping into it. Any heads up about what this is likely coming from?
     
  2. aglareinmyeyes

    aglareinmyeyes

    Thread Starter

    5
    0
    1
    Location: Los Angeles CA
    So far I've heard the pivot plate would be most likely.
     
  3. Pete H

    Pete H

    181
    8
    18
    Location: MK46 5PQ
    I'm sure mine was the detent spring/wheel...had exactly the same 1yr and 1day after I bought it second hand from dealer...to be fair we shared the repair costs 60/40. Fiddly job apparently but has been fine since.
     
  4. aglareinmyeyes

    aglareinmyeyes

    Thread Starter

    5
    0
    1
    Location: Los Angeles CA
    Is that what hits the shift star?
     
  5. Pete H

    Pete H

    181
    8
    18
    Location: MK46 5PQ
    Sorry buddy, didn't do the work myself.
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice